收录日期:2020/11/30 15:30:32 时间:2010-09-07 20:31:25 标签:internet-explorer-8,automation,windows-server-2008,watin

I've created some automated tests using WatiN and MBunit and they run fine on my machine (running Windows 7 and VS 2010).

However, when I try running them on a virtual machine which is running Windows Server R2 2008 and IE8 my tests consistently timeout unless I am clicking into the window periodically.

IE is not in protected mode. Also each time a browser is launched the WatiN "BringToFront" method is called, but it doesn't seem to actually bring the browser to the front, it always opens behind Visual Studio 2010.

Looks like this is caused by two things, one is an IE8 bug, the workaround is to open Tools-> Internet Options -> Advanced and un-check "Show Pictures"

The other fix is to open Regedit, in the folder tree navigate to HKEY_CURRENT_USER\Control Panel\Desktop. Change the ForegroundFlashCount to 0, then log off and on again. (this fix is a per-user setting, so each testing user will need to do the fix)